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Introduction

In this tutorial you will walk through the functionality contained in the framework supplied with
LabVIEW FRC.

A programming framework is piece of default code that provides the overall structure, or architecture,
of your program. It defines interaction between different code sections, and provides designated places
to insert specific functionality.

The frameworks are supplied as a starting point; they let you focus on actual functionality in the limited
time available to you, rather than program architecture.

Creating an FRC Robot Project

From the LabVIEW Getting Started Window, select FRC cRIO Robot Project to create a new LabVIEW
project.
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A dialog box will open. In this box you will name your new project, choose where the project will be
saved, and configure your cRIO IP address.
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For the IP address, replace xx.yy with your team number. For example, if your team number is 1 you
would replace xx.yy with 00.01; if your team number is 1986 then you would replace it with 19.86.

Once you click Finish in this window, the Project Explorer will appear.

The FRC Robot Project

The cRIO Robot Project contains a set of Vis pre-written to use as an out-of-the-box solution for your
robot.

o

{3 Project Explorer - 2012 Robot Project.lvproj E]@

File Edit View Project Operate Tools Window Help
Sep| « IECIEE
Iters | Files
-
=+ N MyComputer

! ‘1:; Dependencies
str Build Specifications
) m RT CompactRIO Target {10.50cyy.2)

i+ () TypeDefs

= [J Team Code
-l Beginwi
- ml Autonomous Independent.vi
-l Teleop.wi
- g Vision Processing.vi
- | Disabled.vi
L.. Periodic Tasks.wi
-|%) Robot Global Data.vi
‘g.} Build DashBoard Data.vi
el Finish.vi
- CJ Vmon Support Code
4 J Support Code
- ] Robot Main.wvi
G+ % Dependencies
=) .30:; Build Specifications

[%] FRC Robot Boot-up Deployment

All of the code is listed under the RT CompactRIO Target in the Project Explorer window to designate
where the code will deploy and execute. The top-level VI of this project is Robot Main.vi. Two folders,

TypeDefs and Team Code, contain the type definitions and subVIs for this project. From here, let’s take
a look at the Robot Main VI.

Robot Main VI

Open Robot Main.vi by double-clicking the filename in the Project Explorer window.
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The first thing to notice is that the Front Panel doesn’t contain any typical user interface controls or
indicators. Since you'll be using the Driver Station and Dashboard to view data from the robot, there’s

no need for these items here. Open the Block Diagram by pressing CTRL+E or by selecting
Window»Show Block Diagram from the menu bar.
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From this framework, we can modify the individual subVIs and type definitions to customize our robot.
It is important to note that you shouldn’t need to modify the Robot Main VI, and it's recommended that
you make changes to the subVIs themselves. Let’s take a look at the components that make up this
framework:

e BeginVi

The Begin VIl initializes sessions for the camera, safety configuration, motor, joysticks, as well as
selecting which version of the Autonomous VI (independent or iterative) we want to use.
Additional initializations should be added to this VI.
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Teleop and Autonomous Modes

This section of code uses a state machinem, which consists of a case structure inside a while
loop. Each time the loop runs, the Get Competition Mode VI will check the current mode and
run the appropriate case from the case structure. When Autonomous Independent is selected
in the Begin VI, the Get Competition Mode VI will execute the Autonomous Independent VI code
in parallel with the Robot Main VI. For the Autonomous Iterative and Teleop modes, you can
modify those VIs for use in this framework.

Start
Start Communication VI @

This VI starts the communication loop between your robot and the driver station. It executes in
parallel with rest of the Robot Main VI.

Build Dashboard Data VI
This VI is used to send data back to the Dashboard, which is raw sensor data by default. It can
be modified to send back custom data. See the Dashboard Tutorial to learn more.

Vision Processing VI @

This VI is one of the two that execute in parallel with your control code. The code acquires
images from the camera and performs some processing which can be used to modify your
robot’s 1/0, variables, motors, etc.



e Timed Tasks VI
This VI executes any additional periodic tasks that need to execute. For example, you may need
to implement a PID control loop. We can execute multiple tasks at different rates. We can also
use the Robot Global Data global variable to pass data between different loops or to the other
Vls.

Adding an Accelerometer to the Periodic Tasks VI

The first step in adding a new sensor to the framework is to decide which loop you want to acquire the
data in. Itisimportant to keep some tasks separate. For example, motor control and image processing
should be separated. If they are in the same loop, both tasks will be limited to the slowest rate. If you
want to acquire data from an accelerometer every 100 ms, you should use the Periodic Tasks VI.

After selecting the appropriate VI to add your sensor to, the first step will be to initialize it. You can do
the initialization in the Begin VI. To open the block diagram of the Begin VI, double-click its icon on the
block diagram of Robot Main VI or its name in the Robot Project Explorer Window. At the bottom of the
Begin VI's block diagram, you’ll place accelerometer initialization code. The accelerometer can then be
referenced in other Vis.
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Add an Accelerometer Open VI and configure it. The VI can be found in the WPI Robotics
Library»Sensors»Accelerometer palette.
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After configuring the accelerometer, you'll need to add the reference to a registry. This registry can be
read in other Vs to get the accelerometer reference. Place an Accelerometer RefNum Registry Set VI
to register the accelerometer. Wire the AccelerometerDevRef output from the Open VI to the
AccelerometerDevRef input of the Registry Set VI. Right-click the refnum name input and select
Create»Constant to name the accelerometer reference. Enter “Accelerometer” into the constant.
You’ll use this name to retrieve the accelerometer reference in the Periodic Tasks VI. Save and close
Begin.vi.
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At this point you are ready to add a Read Accelerometer VI inside the Periodic Tasks VI. Thisis an
excellent opportunity to take advantage of the example code that installs with LabVIEW FRC. To access
the accelerometer example, select View»Getting Started Window from the menubar and click on Find
FRC Examples... in the bottom right of the Getting Started window. Navigate to the Accelerometer
Alarm Example under FRC Robotics»Complete List»Accelerometer Alarm Example.lvproj, and double-
click to open it.
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Open the block diagram of the Accelerometer Alarm Example and the Periodic Tasks VI. Copy and paste
the code from inside the example’s while loop to the Periodic Tasks VI. Inside of the Periodic Tasks VI
you’ll need to read the accelerometer value, so a Get Acceleration VI is required in the second loop. For

this tutorial, you'll implement the limit test code in the example VI. Copy and paste everything except
for the Wait, Unbundle by Name, and stop button from the Acceleration Alarm Example into the
Periodic Tasks VI. To do this, left-click and highlight everything inside the Acceleration Alarm Example
loop and select Edit» Copy. Then go to the Periodic Tasks VI and paste the code into an empty space on
the block diagram using Edit» Paste.
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After copying the example code into the periodic tasks loop, not all of the features are required. Since
you won’t be viewing the front panel while operating the robot, you need to change the controls for the

Center Voltage, Gain (VoltsPerG), Upper Alarm Bound

and Lower Alarm Bound to constants. You can

also remove the Accelerometer Chart because we won’t be viewing this data during robot operation.
The two values of interest would be the Acc Value and In Alarm indicators. These two values may
produce useful information that can be used in the main TeleOp and/or Autonomous Vls.

Follow these steps to clean up the code:

1. Press Ctrl+B to remove all broken wires.
Remove the comments, Accelerometer Chart,

and Bundle function.

Right Click on the Center Voltage Control and select Change to Constant. Do this for the other 3

controls.

4. Remove any additional wires and rearrange the remaining code.
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The final step is to retrieve the accelerometer reference at the start of the Periodic Tasks VI. In this VI,
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Earlier, you added an accelerometer reference named “Accelerometer” and you’ll retrieve it using the
Accelerometer RefNum Registry Get VI (WPI Robotics Library»Sensors»Accelerometer). Right-click the
refnum name input and select Create»Constant. Enter “Accelerometer” into the constant. Expand the
Bundle function and wire the AccelerometerDevRef to the bundle.
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To link the accelerometer to the code in the 100 ms loop, use an Unbundle by Name function
(Programming»Cluster, Class & Variant) to select the accelerometer reference. Wire the reference to
the Accelerometer SetCenterVoltage VI.
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Using the Robot Global Data Variable

At this point, you have the necessary code to read the accelerometer value every 100 ms. However, if
you want to use Acc Value and Alarm to affect your motor control or autonomous VI, you will need a
mechanism to transfer the data. In order to pass data between Vls, you need to use global variables. A
global variable is a link to a memory location that stores data so that all Vls within one project have
access to the value. The framework creates a global variable named Robot Global Data that can be
modified to pass data to the other tasks.

From the Project Explorer Window, double-click Robot Global Data.vi to open the variable editor.
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Here, you can add different Front Panel controls and indicators to access within your Vis. Add a numeric
control named “Acc Value” and a Boolean control named “Alarm.” so that you can pass the data from
the Periodic Tasks VI to other tasks. Save and close the VI.

Add the Robot Global Data to the Periodic Tasks VI by dragging and dropping the global variable from
the Project Explorer Window into the block diagram of the VI.
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Left-click the global variable and select Acc Value to replace the indicator in the while loop. Add
another global variable to replace the Alarm indicator. Save and close the Periodic Tasks VI.

[100 ms tasks go here]
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Any time that you want to access or change the value of either of these variables, you can drag and drop
another copy of the variables onto other block diagrams. This is a great way to read the current
acceleration value in your main loop, so that you can use this information to control the robot.

Note: As a general rule of thumb, you can read from your global variables in several places, but you
should only write to a global variable at one place in your code. If you write to the variable in multiple
places, it can become difficult to determine which value will be saved. When you drag and drop a global
variable, it will be a Write instance by default. You can change this by right-clicking the variable and
selecting Change to Read.

Conclusion

Congratulations! You now have an understanding of the FRC Robot Framework and you’ll be able to
begin customizing the code to your needs. For additional information, refer to the other tutorials at
Getting Started Programming with FRC Hardware.
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